Out of memory issues with Edison

All FL bugs & fixes here. One bug/thread
[You can only see part of this thread as you are not logged in to the forums]
AaronChristopherc
Fri Mar 30, 2012 12:37 pm

Out of memory issues with Edison

I usually record for fairly long periods of time on Edison. Without warning and seemingly randomly I get the error "out of memory" at which point FL studio becomes unresponsive and I have to end the process. This seems to only occur when I'm using Edison. Usually for longer periods of time, but not always. (I have 12 gigs of ram.)

In performance monitor within FL studio I don't think I ever even exceeded 2 gigs. Now either FL studio is only making use of a limited amount of my memory, and therefore running out, or I'm not using that much. OR there's another issue.

I'm unsure if what I'm doing within FL actually utilizes that much memory or not. I've looked over the "improving performance" documentation that came with FL. I did change my power plan to "High performance" so I know there isn't any
CPU throttling. I am using ASIO4ALL sound driver.

I'm sure this HAS been answered before, but if by chance FL isn't making use of all of my available memory, what can I do to resolve this? Does giving the FL studio process in task manager "high priority" actually do ANYTHING?

I have A LOT going on in my projects, at times possibly too much BUT I don't think my performance should be affected the way it is sometimes.

I have 12 gigs of ram and a AMD quad core (not hyperthreded ) I'm on 64 bit Windows 7.

Thanks!
0 x

reflex
Site Admin
Fri Mar 30, 2012 12:40 pm

Re: Out of memory issues with Edison

Short answer: FL, as a 32bit application, can o...
0 x

AaronChristopherc
Fri Mar 30, 2012 12:55 pm

Re: Out of memory issues with Edison

Ah, I see. I don't think I've been using the ex...
0 x

reflex
Site Admin
Fri Mar 30, 2012 1:04 pm

Re: Out of memory issues with Edison

There are some difficulties making a 64bit vers...
0 x

AaronChristopherc
Fri Mar 30, 2012 1:06 pm

Re: Out of memory issues with Edison

Ah yeah, I noticed that in process explorer, no...
0 x


Return to “FL Studio Bugs & fixes”