Click here for (Advanced Forum Search)

Reason doesn't appear on FL's Rewire..

for all your technical questions
Forum rules
IMPORTANT: Please provide AS MUCH INFORMATION as you can, and a TEST PROJECT. Even better, the steps to reproduce your problem. A video can help also. Bugs will be fixed much faster if you follow these suggestions, thank you.
[You can only see part of this thread as you are not logged in to the forums]
Feb 07, 2008 (5:37)
Hi, i've been using FL Studio for a long time and i've just installed Reason 4 so i can use it as a plugin via Rewire.. i open FL Studio, add one Rewire channel, and where you choose the device Reason doesn't appear, still Ableton Live does appear(but it doesn't work, but i don't really care about that one thou), even thou i was able to use Reason 3 via Rewire a few months ago..
iv'e searched for days for an answer but no one seems to have the same problem as i do..
here is my diagnostic report..

Version 1.2.2
This report was generated on 2/6/2008 at 6:28:57 PM

This is the summary. The details for each test can be found further down.

FL Studio 7.0.2 was installed in "C:\Program Files\Image-Line\FL Studio 7"
No other instances were found
You have 16 registered FL plugins or tools
You are running Microsoft Windows Vista
1 ASIO device was found
You have DirectX 9.0
3 DirectSound devices were found
You have 2 DXi softsynths and 1 DX effects installed
FL Studio will look for VST plugins in the following locations:
"C:\Program Files\Image-Line\FL Studio 7\Plugins\VST"
"C:\Program Files\VstPlugins"
The program didn't look for VST plugins
No 3rd party applications that may interfere with FL were found
3 ReWire devices were found
0 MIDI inputs and 1 MIDI output were found
The Ogg Vorbis codec is installed and enabled
SoftVoice is installed
If you need help with any aspect of FL Studio, try the following links: FL website:
Technical issues (bugs): TechSupport forum
FL Studio community: Looptalk forum
Frequently asked questions: Knowledgebase
Registration problems: Support request

FL test results
1 installation of FL was found
1. FL Studio 7.0.2
Location: "C:\Program Files\Image-Line\FL Studio 7"
Username: "32383636373332656A7B756F627B624C7470666975624E"
VST plugins will be searched in:
"C:\Program Files\Image-Line\FL Studio 7\Plugins\VST"
"C:\Program Files\VstPlugins"
Audio device: Speakers (Realtek High Definition Audio)
Audio buffer size: 53ms
Audio sample rate: 44100Hz
Interpolation method: 6-point Hermite

FL will use the slicer tool located at "C:\Program Files\Image-Line\FL Studio 7\System\Tools\BeatSlicer\zx_bs_d.exe"
You have 16 registered FL plugins or tools
[31020] FL Studio Producer Edition
[33000] DrumSynth Live
[33110] SimSynth Live
[33300] WASP
[33400] Dreamstation
[33500] Slayer II
[37020] DX10
[37021] DX10 VSTi/DXi
[37030] SoundFont Player
[37040] Sytrus FM Synth
[37041] Sytrus FM Synth VSTi/DXi
[37050] VideoPlayer
[37060] FL Studio XXL Box v6.0
[37061] DirectWave
[37110] SimSynth Live VSTi
[37310] Wasp VSTi

System test results
You are running Microsoft Windows Vista, version 6.0 (32bit)
You don't have a servicepack installed
Windows is installed in "C:\Windows"
The program files location is "C:\Program Files"
The default browser appears to be "C:\Program Files\Internet Explorer\iexplore.exe"
Your system has 2 processors
The cpu is a AMD Turion(tm) 64 X2 Mobile Technology TL-50 running at 802MHz
Instruction support: FPU CMOV SSE SSE2 SSE3 x64 DAZ
You have 1022MB physical and 2048MB virtual memory
You have 1 monitor set to 32bit color for a desktop resolution of 1440x900 pixels
You have administrator privileges

3rd party software
No 3rd party applications that may interfere with FL were found

DirectX test results
You have DirectX 9.0 installed
DirectX reported version
You have 3 DirectSound devices
Primary Sound Driver
Speakers (Realtek High Definition Audio)
Realtek Digital Output (Realtek High Definition Audio)
You have 2 DXi softsynths and 1 DX effects installedName Kind I/O
Antares Auto-Tune 4 effect 1/1
IL FL Studio DXi synth (DXi)
IL Multi FL Studio DXi synth (DXi)

ASIO test results
1 ASIO device was found
1. ASIO4ALL v2
It has 0 input channels and 0 output channels
The following samplerates are supported:

VST test results
Global VST path: %VSTPLUGINS%
The program didn't look for VST plugins

ReWire test results
ReWire uses ReWire.dll with version 1.7
3 ReWire devices were found
1. ASIO4ALL ReWire Input
2. FL Studio
3. Reason

MIDI test results
0 MIDI inputs and 1 MIDI output were found

as you can see, in the Rewire results you can see that it detects Reason, but in FL Studio does not..
Help me please..

Site Admin
Feb 07, 2008 (9:31)
That's really weird, cause they use the exact s...

Feb 08, 2008 (2:02)
i've tried restarting FL Studio like a hundred ...

Site Admin
Feb 10, 2008 (9:43)
I have no idea why this would happen. I sugges...

Feb 11, 2008 (8:22)
still the same.. so.. nobody in there has an id...

Feb 11, 2008 (8:22)
still the same.. so.. nobody in there has an id...

Site Admin
Feb 11, 2008 (9:51)
Does Reason show up as a ReWire device in other...

Feb 12, 2008 (0:53)
Live won't detect Reason or FL Studio..

Site Admin
Feb 12, 2008 (10:50)
Looks like a problem with the Reason dll then. ...

Site Admin
Feb 12, 2008 (11:48)
Does it say 4.0 on the splash screen (when you ...

Feb 13, 2008 (1:51)
Reason 4 Version 4.0 (Build 905)

Site Admin
Feb 13, 2008 (13:46)
The latest one is 4.0.1. Could you try updating...

Feb 15, 2008 (9:06)
i tried to find the update but something happen...

Feb 15, 2008 (9:06)
sorry.. i meant to say a .0.1 update..

Site Admin
Feb 15, 2008 (9:09)
LFLO45 wrote:sorry.. i meant to say a .0.1 upda...

Feb 16, 2008 (3:17)
well.. i've installed the Reason update.. now i...

Site Admin
Feb 16, 2008 (11:26)
I would try uninstalling both FL and Reason, th...

Feb 18, 2008 (16:10)
just like to commiserate with LFL045. i too can...

Feb 27, 2008 (14:39)
Make Sure You are using Same ASIO Device.choos...

Feb 28, 2008 (21:30)
when i choose ableton live as a preset there's ...

Tom Ellard
Feb 29, 2008 (1:41)
I've had problems with rewire before, it can so...

Mar 02, 2008 (12:43)
i've found 3 rewire.dll.. 1 on the reason folde...

Mar 02, 2008 (12:45)
Tom.. could you tell me more about that midi lo...

Site Admin
Mar 03, 2008 (11:42)
LFLO45 wrote:i've found 3 rewire.dll..1 on the ...

Mar 06, 2008 (6:36)
i had that same problem,,,,in the end i format...

Red Phoenix
Mar 08, 2008 (0:33)
I have that same problem with rewire except wit...

Click here for (Advanced Forum Search)