wrapper 2.4.x (2014/04/09)

Here you can find (time limited) beta's for plugins & program components
[You can only see part of this thread as you are not logged in to the forums]
reflex
Site Admin
Nov 21, 2011 (15:21)
version 2.4.29

The wrapper is the interface between FL Studio and VST plugins.

You'll also have to install the shared program files:
http://forum.image-line.com/viewtopic.php?f=1919&t=97267

Note that this wrapper is meant for FL 11. It may work in earlier versions, but it may also not.

How to install
1. Download the attached zip file.
2. Extract its contents into the FL Studio folder. It will overwrite 6 files.

Changes
(2.4.29)
- bridged plugins no longer show message boxes, their messages are shown in the debug log instead

(old)
- fixed crash related to parameter automation
- reverted some changes from 2.4.24
- fixed bug loading CC parameter event values when the plugin is bridged
- some changes to the way VST3 plugin editors are handled
- fixed Virus TI (VST3) crash
- fixed crash in 64bit VST2 plugins in FL 64bit (when using a lot of memory)
- fixed freeze with VPS Metrum x64 (and potentially with other plugins)
- another fix to closing ilbridge instances
- small fix to showing "bridged plugin has closed" messages
- fixed closing of ilbridge instances
- wrapper dlls are now signed
- error message "... was saved with newer version" is now shown inline instead of as a message box
- fixed updating interfaceless editor controls for bridged plugins
- forward key messages from plugins to FL
- increased chance of closing ilbridge instances when plugin or FL is closed
- fixed crash with MCompressor VST3 parameter changes
- fixed potential memory leak in VST3 plugins
- bridge executables are now signed
- fixed keyboard input in some VST 3 plugins
- added context menu support for (some) VST 3.5 plugins
- small changes
- fixed default value of pitch bend range for old settings (< FL 9.1)
- fixed potential abstract function calls
- removed change to the way plugins are loaded
- fixed loading plugin settings from old FL versions (FL 8 or older)
- experimental change to the way bridged plugins are loaded
- fixed loading bridged plugins from FL10 songs
- fixed access violation loading WaveShellVST in Patcher
- fixed loading multiple instances of Waves VST3 plugin
- fixed automation of bridged VST plugin parameters
You do not have the required permissions to view the files attached to this post.

Hikoku Nakagawa
 
Nov 30, 2011 (14:41)
PLAY x64 Working!!Great work!;)p64.jpg
You do not have the required permissions to view the files attached to this post.

A/V4U
 
Dec 04, 2011 (3:41)
I just read about this update in other thread. ...

AbstractCats
 
Dec 06, 2011 (19:45)
How is the wrapper installed? Copy and paste in...

reflex
Site Admin
Dec 07, 2011 (9:21)
AbstractCats wrote:How is the wrapper installed...

TranceCrafter
 
Dec 08, 2011 (6:31)
OMGYESSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS...

JRokujuushi
 
Dec 13, 2011 (5:23)
Being able to load 64-bit Play is nice, but now...
You do not have the required permissions to view the files attached to this post.

byo
 
Dec 14, 2011 (0:03)
Wow, Play x64!!! That's a dream come true!Thank...

JRokujuushi
 
Dec 14, 2011 (6:02)
Just downgraded to 2.3.5 from this thread and I...

reflex
Site Admin
Dec 14, 2011 (9:24)
Tansunn wrote:Just downgraded to 2.3.5 from thi...

JRokujuushi
 
Dec 14, 2011 (13:15)
I never had any issues with Kontakt until I mad...

reflex
Site Admin
Dec 14, 2011 (16:43)
Tansunn wrote:I never had any issues with Konta...

baswels
 
Dec 14, 2011 (19:43)
Can open play 64 now (thank god) but when i sav...

JRokujuushi
 
Dec 15, 2011 (1:46)
reflex wrote:Does it happen (with 2.3.7) if you...

Hikoku Nakagawa
 
Dec 15, 2011 (17:24)
aww... me tooI tried to downgrade Kontakt anywa...

byo
 
Dec 19, 2011 (0:13)
EWQL Play x64 is working great but I detected a...

byo
 
Dec 22, 2011 (5:12)
After using wrapper version 2.3.7.10 testing th...
You do not have the required permissions to view the files attached to this post.

reflex
Site Admin
Dec 23, 2011 (14:14)
byo wrote:#1) It's still happening after closin...

reflex
Site Admin
Dec 23, 2011 (16:29)
I've uploaded a new version, but I'll be out of...

byo
 
Dec 23, 2011 (21:35)
Thank you, Fred. I will test the other issue an...

Kevvviiinnn
 
Dec 25, 2011 (7:08)
I'm using the new wrapper (2.3.7.15) with an EW...

gol
 
Dec 26, 2011 (6:01)
- voice slides are now linked to polyphonic aft...

byo
 
Dec 26, 2011 (16:23)
Kevvviiinnn wrote:I'm using the new wrapper (2....

kelwynshade
 
Dec 30, 2011 (18:15)
I'll definitely be installing this update this ...

Kevvviiinnn
 
Dec 30, 2011 (23:17)
kelwynshade wrote:I'll definitely be installing...

kelwynshade
 
Jan 01, 2012 (16:52)
I'll try this out and let you know what comes o...

wizanda
 
Jan 03, 2012 (10:45)
Do you think you could make the voice slides 'u...
Last edited by wizanda on Tue Jan 03, 2012 11:02 am, edited 1 time in total.

reflex
Site Admin
Jan 03, 2012 (10:53)
wizanda wrote:Do you think you could make the v...

wizanda
 
Jan 03, 2012 (11:06)
You're so quick to reply Reflex.... Configurabl...

reflex
Site Admin
Jan 03, 2012 (11:16)
wizanda wrote:Configurable as in allowing any c...

reflex
Site Admin
Jan 03, 2012 (11:17)
wizanda wrote:Bug report also wrote:Access viol...

wizanda
 
Jan 03, 2012 (11:23)
reflex wrote:Any 64bit project?Just testing sav...
You do not have the required permissions to view the files attached to this post.

wizanda
 
Jan 03, 2012 (11:39)
reflex wrote:It's already possible to automate ...

reflex
Site Admin
Jan 03, 2012 (11:49)
wizanda wrote:Is it possible to link that to th...

wizanda
 
Jan 03, 2012 (12:28)
Yes, that the two 'unsupported parameter' pinao...

reflex
Site Admin
Jan 03, 2012 (12:29)
I'll see, can't promise anything.

Rolf Music
 
Jan 06, 2012 (11:07)
I fully tested the new wrapper for 4 days and m...

Itscmurph
 
Jan 14, 2012 (4:52)
I feel dumb. How do you extract the file into t...

byo
 
Jan 15, 2012 (14:20)
Itscmurph wrote:I feel dumb. How do you extract...

Scury
 
Jan 15, 2012 (17:42)
Thank you, it finally works !!!

Kevvviiinnn
 
Jan 26, 2012 (1:04)
2.3.7.30 doesn't seem to be cooperating with Pl...
You do not have the required permissions to view the files attached to this post.

reflex
Site Admin
Jan 26, 2012 (8:48)
Kevvviiinnn wrote:2.3.7.30 doesn't seem to be c...

Kevvviiinnn
 
Jan 26, 2012 (19:36)
reflex wrote:Kevvviiinnn wrote:2.3.7.30 doesn't...

Kevvviiinnn
 
Feb 03, 2012 (3:31)
Question: how do I get the aftertouch parameter...

Aura_Qualic
 
Feb 09, 2012 (22:24)
I don't know if this is normal but I'm having a...
You do not have the required permissions to view the files attached to this post.

reflex
Site Admin
Feb 13, 2012 (10:36)
dj Aura_Qualic wrote:I don't know if this is no...

Aura_Qualic
 
Feb 22, 2012 (16:12)
reflex wrote:dj Aura_Qualic wrote:I don't know ...
You do not have the required permissions to view the files attached to this post.

DESELVER
 
Feb 23, 2012 (6:34)
+1forum.image-line.com/viewtopic.php?f=1919&...

reflex
Site Admin
Feb 23, 2012 (10:01)
dj Aura_Qualic wrote:the non bridge CPU usage i...

reflex
Site Admin
Feb 23, 2012 (11:18)
dj Aura_Qualic wrote:the non bridge CPU usage i...

Next