Connecting to Authorize.net

EzGenerator V4 forum
[You can only see part of this thread as you are not logged in to the forums]
Opus4one
 
Mar 15, 2012 (23:13)
Hi,

Probably something dumb on my part, but I can't seem to get connected to Authorize.net - either their real gateway or test account.

Authorize.net has a sandbox/test arena that you access through their test mechanism, so you sign up for a test account and they give you a test LoginID and Transaction Key. They confirmed that you access the test account through the same gateway as what's in the Shop Settings->Payment grid: https://test.authorize.net/gateway/transact.dll. I put in my "test" ID and Transaction Key there as well. For the checkout page, I changed the ec_PaymentMethod field to have "Credit Card...authorize.net" first, then "Bankwire...bankwire" second. No PayPal while testing.

Purchase workflow goes well, products tally and display on cart correctly, press "Checkout" on the Cart Button and it takes me to the form for the customer to fill out, and then when I hit "Checkout" at the bottom (which produces a javascript:void(0)), nothing happens. I can't find an "Authorize.net" payment button in the macros field, so I'm presuming that other than PayPal, the SHOP_CHECKOUT_BUTTON% entry is standard for all non-PayPal gateway providers.

Can you help me with what I'm missing and/or can otherwise try?

Atanas Angelov
Site Admin
Mar 16, 2012 (11:53)
Hi,There is special layout for Authorize.net. Y...
Atanas Angelov
Image Line

Opus4one
 
Mar 18, 2012 (2:58)
Hi Atanas. What you suggest makes sense, but f...

Atanas Angelov
Site Admin
Mar 19, 2012 (13:54)
Hi,We both (me and Miro) started checking here ...
Atanas Angelov
Image Line

Opus4one
 
Mar 19, 2012 (16:35)
Thank you for looking into this...willl be happ...

miro
Site Admin
Mar 19, 2012 (16:47)
hifix is available in latest update please upda...
need help with EZG?

miro
EZGenerator support
Image line

Opus4one
 
Mar 20, 2012 (2:44)
Progress...now problems with the way things are...
You do not have the required permissions to view the files attached to this post.

Opus4one
 
Mar 20, 2012 (4:09)
Just a P.S. Authorize.net says that x_relay_ur...

miro
Site Admin
Mar 20, 2012 (10:24)
hiplease update again, at least return page sho...
need help with EZG?

miro
EZGenerator support
Image line

Opus4one
 
Mar 20, 2012 (14:35)
- Did Shift/Online Update to get latest, full u...

miro
Site Admin
Mar 20, 2012 (17:24)
hii can reproduce this (missing tax on return p...
need help with EZG?

miro
EZGenerator support
Image line

Opus4one
 
Mar 20, 2012 (23:57)
Hi Miro,Thank you for all your help. I know th...

miro
Site Admin
Mar 21, 2012 (22:59)
hiwill think about shipping idea, but this is f...
need help with EZG?

miro
EZGenerator support
Image line

Opus4one
 
Mar 22, 2012 (0:46)
Hi Miro. Initial testing looks good...I know y...

Opus4one
 
Mar 22, 2012 (4:29)
Things still look good. Had a brief situation ...

Click here for (Advanced Forum Search)