Please Help - URGENT (regarding shop callback issue)

EzGenerator V4 forum

Return to “Ezgenerator v4 Customer Forum”

[You can only see part of this thread as you are not logged in to the forums]
Nyrican11
Thu Oct 04, 2018 5:34 pm

0 x

Please Help - URGENT (regarding shop callback issue)

Hello,

I am at a loss as to what to do or what to fix regarding my shop. I've had no issues until more recently within the last week or two that I know of, to which my shop is no longer going to the "return" page after someone purchases an mp3 from my website.

I've looked into Paypal and the Auto Return is on, the IPN url is correct, both are set as needed, and I hadn't initially touched anything either with the settings yet started to experience issues with my site.

It seems that when a customer goes to my site, and makes a purchase, it takes them to the Paypal screen properly, they put in their information, pay, and the payment is done correctly. However, after payment goes through, it takes the customer (and me upon testing) to a blank page with the following:

error processing order (order number), try to reload page or contact shop administrator

It seems the Cancel URL works properly. But the Return URL does not. I have attached an image to the Shop Control String that I have that seems to not be working now for some reason that you can see. It was working fine with the same setup before, but not sure why it is not doing so now.

With regards to the "rm" string, I've tested 0, 1, 2, and 3 (which was in there originally and was working fine though not sure where 3 came from as I've not touched the strings in a long time), and neither of the numbers takes me back to the return URL.

The URLs I have set up are as follows:

In Paypal Auto Return: https://www.genycis.com/beatfolder/shop4beats.php?action=return
In IPN settings Paypal: https://www.genycis.com/beatfolder/shop4beats.php?action=callback

I am not sure what else to check for as to how to correct this to work properly again. Any thoughts are greatly appreciated. Not sure if Paypal made some recent changes that impacted this, and if any of you all are experiencing Shop problems as a result. Keep me posted. Thanks!
You do not have the required permissions to view the files attached to this post.



Return to “Ezgenerator v4 Customer Forum”