32bit mode under MacOSX seems sketchy for GUIs (while 64bit works)

Place to share Minihost Modular presets & discuss

Return to “Minihost Modular - Presets & Programming”

[You can only see part of this thread as you are not logged in to the forums]
subatomic
Tue May 15, 2018 11:56 pm

0 x

32bit mode under MacOSX seems sketchy for GUIs (while 64bit works)

Running MiniHost Modular in 32 bit mode, MacOSX High Sierra.

I wrote a simple test instrument VST2.4 (with Apr8 2018 latest vstgui) that runs under Ableton8 32bit and Vst Lord (also 32bit).
The source code is here:
https://github.com/subatomicglue/MinimalSynthVST2.4

Problems in MiniHost Modular 32bit mode
When opened under MiniHostModular running 32bit mode (right click, get info, change to 32bit, then relaunch)
This VST opens:
- as a white rectangle (should be color background matching the PNG)
- with the correct dimensions (same as PNG)
- after open/close/open/close of the VST, minihost will crash...

Under MiniHost Modular 64bit, it works flawlessly.


Running though several commercial VST2.4 instrument plugins. Under 32bit, Many of the GUIs...
1.) ...appear shifted to the right (big white rectangle where the GUI should be, and the plugin's color GUI offset to the right by 100-200px). some when reopened, then do appear in the correct location.
2.) ...crash the app totally
3.) ...just a white rectangle opens, no color GUI... sometimes crashes the app after opening/closing a few times, sometimes not.
4.) some work fine.



I've boiled the code down to a very minimal simple example.
If anyone could take a look and tell me what I'm doing wrong, I'd appreciate it:
- Editor code (MinimalEditor.h)
- Other source files (MinimalEditor.h, MinimalEffect.h/cpp)




Return to “Minihost Modular - Presets & Programming”