Helm VST output is mono Topic is solved

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
CORONAVIRUS (COVID-19) ANNOUNCEMENT

We know many of you are locked-in or under quarantine restrictions at the moment. Our support staff are based in Europe, so they too are being affected by the current situation. We appreciate your patience during this difficult time as we may not be able to respond to support requests quickly as we would like.

Image-Line Management Team

WE NEED DETAILS: Your problems will be addressed faster if you follow these suggestions:

  1. Update - Before anything else, download and install the latest version of FL Studio from here. Your bug may be fixed already!
  2. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  3. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  4. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  5. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.
[You can only see part of this thread as you are not logged in to the forums]
RefractorDJ
Fri Apr 05, 2019 6:49 pm

x

Helm VST output is mono

Hi,
FL Studio doesn't seem to recognize Helm can output stereo (which, while Helm doesn't have a lot of stereo imagery options at the moment, it still outputs stereo sound), only taking one channel out of the plugin and into FL. The standalone version sounds stereo, and using another VST host works fine as well.

In the video below I try Helm VST in FL Studio, then Standalone, then loading it in VST Host.



I've also tested the LV2 version on Linux which also outputs stereo, which is further proof the bug is on FL Studio's side, and not Helm's.

Nothing fancy was done, just get Helm and install. Then add to FL Studio.

reflex
Site Admin
Thu Apr 11, 2019 8:44 am

x

Re: Helm VST output is mono

It looks like the VST 2 version is stereo and t...

RefractorDJ
Thu Apr 11, 2019 7:49 pm

x

Re: Helm VST output is mono

reflex wrote:It looks like the VST 2 version is...

Robiaster
Technical Support
Fri Apr 12, 2019 11:19 am

x

Re: Helm VST output is mono

Let us know if you find anything.


Devan.P
Thu Mar 26, 2020 6:31 pm

x

Re: Helm VST output is mono

RefractorDJ wrote: ↑Thu Apr 11, 2019 7:49 pm re...

Evyi
Technical Support
Tue Mar 31, 2020 12:13 pm

x

Re: Helm VST output is mono

With host is another program like FL Studio mea...


Return to “Technical Support (Windows)”