Midi CC automation is broken.

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
WE NEED DETAILS: Your problems will be addressed faster if you follow these suggestions:

  1. Specific information - a) FL Studio version number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  2. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  3. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  4. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.
[You can only see part of this thread as you are not logged in to the forums]
HSJIII
Sat Apr 13, 2019 11:11 pm

0 x

Midi CC automation is broken.

Here is an upload of the project I'm talking about. It isolates the issue.
cc controller is broken.flp


Load that project first. Now, in the project, there is a Midi Out plugin in the channel rack.
The plugin is programmed to use:
Port: 0

The plugin's first knob is configured to drive a MIDI CC signal at:
Channel 1
CC number 127

Please, take a look at the first plugin, in channel rack, and confirm that this MIDI  Out is configured that way... right click that knob, and click "configure", to see its settings. So moving its first knob should send out a MIDI CC Signal on Channel 1, CC Number 127, Port 0. Now hit "play" on the project, with "SONG" activated in the FL Studio transport controls. You should see the first knob in that MIDI Out plugin moving with the automation.

Now, in channel rack, there are two MIDI Out plugins. The second one has channel volume moving. The first one does not. Now, the first one SHOULD be moving, too... but MIDI CC signals are failing to move it, despite the fact that it's configured to move with MIDI CC's from the first knob in the top MIDI Out plugin.

Unless it's got to do with my FL config, or my system, I believe this possibly is a bug, (and a major one, for me, at least); my more complex projects are deeply dependent on MIDI CC signals WITHIN FL. :(

NOTES:
For what it's worth, the same thing happens when I try to drive the automation with MIDI CC automation signals from the FL Dashboard plugin, too. MIDI CC automation is failing, for me, overall.

Normal FL Automation is working, (as seen in the second plugin's channel rack volume knob moving) but this category of FL automation can't do what I need. It has to be MIDI CC.

Thanks for reading this. Please advise.

Oh, incidentally: My system is FL 64, on Windows 7-64.
You do not have the required permissions to view the files attached to this post.

HSJIII
Sun Apr 14, 2019 3:20 am

0 x

Re: Midi CC automation is broken.

Incidentally, my efforts to understand this pro...

reflex
Site Admin
Thu May 09, 2019 12:51 pm

0 x

Re: Midi CC automation is broken.

HSJIII wrote:Please, take a look at the first p...

HSJIII
Thu May 23, 2019 7:52 pm

0 x

Re: Midi CC automation is broken.

reflex wrote:HSJIII wrote:Please, take a look a...

steevm
Thu May 23, 2019 8:16 pm

0 x

Re: Midi CC automation is broken.

You can use virtual MIDI drivers to do this in ...

NTO
Thu May 23, 2019 8:24 pm

3 x

Re: Midi CC automation is broken.

I use virtual ports often. Started having prob...

HSJIII
Fri May 24, 2019 10:11 pm

0 x

Re: Midi CC automation is broken.

NTO wrote:I use virtual ports often. Started h...

HSJIII
Fri May 24, 2019 10:42 pm

0 x

Re: Midi CC automation is broken.

NTO wrote:I use virtual ports often. Started h...

NTO
Sat May 25, 2019 12:12 am

0 x

Re: Midi CC automation is broken.

The loopmidi is a bridged config. Easy to send...
You do not have the required permissions to view the files attached to this post.

HSJIII
Sat May 25, 2019 10:43 pm

0 x

Re: Midi CC automation is broken.

NTO wrote:The loopmidi is a bridged config. Ea...

NTO
Sun May 26, 2019 3:07 pm

0 x

Re: Midi CC automation is broken.

First, I would suggest you post your actual que...
You do not have the required permissions to view the files attached to this post.
Last edited by NTO on Mon May 27, 2019 8:32 pm, edited 1 time in total.

HSJIII
Mon May 27, 2019 7:03 pm

0 x

Re: Midi CC automation is broken.

Well, first off that plugin does not load, so y...

NTO
Mon May 27, 2019 8:29 pm

0 x

Re: Midi CC automation is broken.

HSJIII wrote:Well, first off that plugin does n...
You do not have the required permissions to view the files attached to this post.


Return to “Technical Support (Windows)”