FL ASIO problems with 96k sample rate Topic is solved

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
WE NEED DETAILS!

We appreciate your frustration when things don't work as you expected. However, please help us to help you by following these suggestions:

  1. Update - Before anything else, download and install the latest version of FL Studio from here. Your bug may be fixed already!
  2. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  3. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  4. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  5. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
zippy731
Tue Feb 18, 2020 3:40 am

x

FL ASIO problems with 96k sample rate

I'm consistently having a problem that FL Studio crashes when I switch to 96K sample rate while using FL ASIO. I can run 96K in FLS using ASIO4all, but FL asio will just crash.

See attached video.

If I launch FLS with normal 44.1 sample rate and FL ASIO, no problem. If I then switch to FL ASIO 96K, it continues working in that session, but next time I try to launch the app it will immediately crash, just before it makes the startup sound. It does this even if I restart my PC.

Once it's crashed in this way, it will continually crash on any try to restart the program. My only solution has been to use FL diagnostics and reset my personal settings.

After resetting my settings, it will often crash on launch one more time while trying to load the sample project, but will work thereafter when loading an empty template FLP.

Because it's crashing before startup is complete, it's not generating any crash logs. However, a sample startup log is attached below.

If I do these same steps with ASIO4All (launch w/ 44.1k, switch to 96k, quit and relaunch) there are no problems, and it seems stable.



This is a new problem for me. I've been using FLASIO for several years, with 96k and 44.1 sample rates, with no issues.

I did try reinstalling FL ASIO (from this link: viewtopic.php?f=1919&t=141121) but it didn't have any effect.

I recently upgraded my PC to Windows 10, and also recently upgraded to the latest FLS (v20.6.2 build 1549 Signature bundle, 64bit) so I'm not sure which might have caused this.

I'm running Windows 10 Home 64bit, on an older DELL XPS 8300 w/ 16G Ram and i7-2600 CPU.

Any suggestions would be welcome!

Thanks,
Chris


Launch Fail Log:

===========BEGIN LOG=========
C:\Users\Chris\Documents\Image-Line\FL Studio\Support\Logs\Startup\Startup 2020-02-17_192649.log
HostVersion=1 Flags=00000000
FL Studio v20.6.2.1549
BeforeRunning
Starting at 7:26:49 PM
64Bit addressing mode
3DNow! support: no
SSE support: yes
SSE2 support: yes
SSE3 support: yes
SSSE3 support: yes
AVX support: yes
Touchscreen not available
Main GUI scaling factor: 1 (system set to 96PPI)
Temporary folder for this session:
C:\Users\Chris\AppData\Local\Temp\Image-Line\{DB51DBD8-B23C-466C-95A6-7260F1EB688F}\
---
ReadIniFile
Restore window state
Restore settings window
Assigned(MIDIForm) =
Read various options
Read more options
Load MRU list
Restore more window settings
Animation timer set to 16ms, vsync enabled
Read audio options
Update tools menu
Init things
Mixer track map: 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125
---
Mixer threading map rebuilt: 1 layer(s)
Layer 1: 1 unit(s)
Unit 1: track(s) 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125
---
Opening ASIO driver: FL Studio ASIO version 1
Buffer length: 4096 frames
In/out latency: 7734/8845 frames
Time out: 76ms (7296 frames)
---
Opening MIDI output devices
Opening MIDI input devices
Loading FLP file: C:\Program Files (x86)\Image-Line\FL Studio 20\Data\System\PreviewTrack.fst
Loading project: version 4.5.4
---
Update browser
Update channel rack
Update toolbars and stuff
Restore settings for most windows
Init DWM
Loading FLP file: C:\Program Files (x86)\Image-Line\FL Studio 20\Data\System\Empty.flp
Mixer track map: 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125,0
---
Mixer threading map rebuilt: 2 layer(s)
Layer 1: 1 unit(s)
Unit 1: track(s) 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125
Layer 2: 1 unit(s)
Unit 1: track(s) 0
---
Loading project: version 9.6.0
---
Mixer track map: 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125,100,101,102,103,0
---
Mixer threading map rebuilt: 3 layer(s)
Layer 1: 1 unit(s)
Unit 1: track(s) 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125
Layer 2: 1 unit(s)
Unit 1: track(s) 100,101,102,103
Layer 3: 1 unit(s)
Unit 1: track(s) 0
---
ReadIniFile - end
ProcessFirstTimeStuff
Clear playlist and create new project
Loading FLP file: C:\Program Files (x86)\Image-Line\FL Studio 20\Data\Templates\Minimal\Basic with limiter\Basic with limiter.flp
Mixer track map: 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125,0
---
Mixer threading map rebuilt: 2 layer(s)
Layer 1: 1 unit(s)
Unit 1: track(s) 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125
Layer 2: 1 unit(s)
Unit 1: track(s) 0
---
Loading project: version 20.5.0.1099
---
Mixer track map: 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125,0
---
Mixer threading map rebuilt: 2 layer(s)
Layer 1: 1 unit(s)
Unit 1: track(s) 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125
Layer 2: 1 unit(s)
Unit 1: track(s) 0
---
Play startup sound

=================LOG ENDS=============
You do not have the required permissions to view the files attached to this post.

Evyi
Technical Support
Wed Feb 19, 2020 4:34 pm

x

Re: FL ASIO problems with 96k sample rate  Topic is solved

Hi there. It doesn't make sense to work with F...


Evyi
Technical Support
Fri Feb 21, 2020 3:39 pm

x

Re: FL ASIO problems with 96k sample rate

Ah, I wondered about why you need more than 44....


N00B1O1
Wed Feb 26, 2020 1:26 am

x

Re: FL ASIO problems with 96k sample rate

zippy731 wrote: ↑Sat Feb 22, 2020 2:02 am Cool,...


Modul
Thu Feb 27, 2020 4:30 pm

x

Re: FL ASIO problems with 96k sample rate

Hey, if you use ASIO4All driver, go to the fol...
You do not have the required permissions to view the files attached to this post.


Return to “Technical Support (Windows)”