Windows Vista, FL Studio and ASIO4ALL

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
WE NEED DETAILS!

We appreciate it's frustrating when things don't work as expected. However, please help us to help you by following these suggestions:

  1. Simple clear explanation - Explain what you are doing, or trying to do, and exactly what is happening.
  2. Update - Before trying anything else. Download and install the latest version of FL Studio from here. Your bug may be fixed already!
  3. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  4. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  5. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  6. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
ingemarc
Sat Oct 27, 2007 3:30 pm

x

Windows Vista, FL Studio and ASIO4ALL

In short: Cannot record with mic into FL Studio but I can do it to Vistas soundrecorder. I have spent hours with helptext and FAQ to solve my problem so please direct me if this is trivial.

Background:
I have a new computer (2 weeks ago) aimed for among other things for music and FL Studio. I have downloaded the demo and will buy one more flexible version if the demo works on my computer

The computer in short:
Fujitsu Semens Scaledo pa 2512
AMD Athlon 64 x2 Dual Core Processor 4000+ 2.10 GHz.
1023 MB
32 bit
Windows Vista Home edition.
I understand it as the sounddevice is integrated on mother board
It uses driver "High Definition Audio Device (Microsoft)".

This is not enough for FL Studio so I have found ASIO4ALL and downloaded latest beta and latest non beta. It appears in FL St. (I think maybe it also was there already inte the demo installation). I can choose Options -> Audio settings -> ASIO4ALL v 2 but then the sound is dead. If I go back in the same list to the choice "primary sound device" the sound is back but no possibility to record from mic.

How is the procedure of for example deactivate/activate/install/uninstall drivers best done? And how is ASIO4ALL installed and used for success in my case?

Grateful for any help!

ingemarc
Mon Oct 29, 2007 2:29 pm

x

Re: Windows Vista, FL Studio and ASIO4ALL

ingemarc wrote:In short: Cannot record with mic...

reflex
Site Admin
Mon Oct 29, 2007 2:34 pm

x

Do you have the Asio4All driver selected? Do y...

ingemarc
Mon Oct 29, 2007 4:17 pm

x

reflex wrote:Do you have the Asio4All driver se...
You do not have the required permissions to view the files attached to this post.

reflex
Site Admin
Mon Oct 29, 2007 5:32 pm

x

If you haven't already, download and install th...

ingemarc
Mon Oct 29, 2007 6:41 pm

x

reflex wrote:If you haven't already, download a...

reflex
Site Admin
Mon Oct 29, 2007 8:39 pm

x

ASIO should work in the demo version too (the o...


Return to “Technical Support (Windows)”