BUG REPORT: Re: Patcher, Convolver & Synthmaker

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
WE NEED DETAILS!

We appreciate it's frustrating when things don't work as expected. However, please help us to help you by following these suggestions:

  1. Update - Before trying anything else. Download and install the latest version of FL Studio from here. Your bug may be fixed already!
  2. Simple clear explanation - Explain what you are doing, or trying to do, and exactly what is happening.
  3. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  4. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  5. A video - The best way of demonstrating many issues. Windows 10 includes an integrated screen recorder, see here OR get a free free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  6. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
funkytecknician
Fri Jul 06, 2012 5:00 pm

x

BUG REPORT: Re: Patcher, Convolver & Synthmaker

Nested Patcher presets (i.e., a Patcher within a Patcher) tend to cause embedded Convolver presets to fail at loading their appropriate convolution impulses.

I created an instrument Patcher patch that incorporates Convolver. I wanted to make a section (i.e., multiple instruments playing at once) so I nested them within one Patcher. The Convolver plugins within the child Patcher instruments fail to load their impulses but seem to keep other state variables, such as EQ settings, the stretch factor, etc.

The impulses that I use are contained in FL's "search folders", but are of my own design.

Furthermore, I quite often get a bug when creating complex instruments (e.g., 5-10 nested Sytrus patches) in Patcher. It simply says "If you see this, this is a bug. Contact me."

Finally, nested Synthmaker instrument patches within Patcher tend to exhibit hanging notes. This is especially the case when layered with a Sytrus patch.

Let me know if you need any extra information.

Thanks,
Nick

reflex
Site Admin
Mon Jul 09, 2012 7:30 am

x

Re: BUG REPORT: Re: Patcher, Convolver & Synthmaker

Could you make presets that exhibit these probl...

funkytecknician
Wed Jul 11, 2012 10:57 pm

x

Re: BUG REPORT: Re: Patcher, Convolver & Synthmaker

Alright, I've attached a Patcher instrument pre...
You do not have the required permissions to view the files attached to this post.

reflex
Site Admin
Thu Jul 12, 2012 1:55 pm

x

Re: BUG REPORT: Re: Patcher, Convolver & Synthmaker

Hm, could you post a screenshot of convolver wi...


Return to “Technical Support (Windows)”