Need help, having trouble when trying to record vocals over created beat.

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
WE NEED DETAILS!

We appreciate your frustration when things don't work as you expected. However, please help us to help you by following these suggestions:

  1. Update - Before anything else, download and install the latest version of FL Studio from here. Your bug may be fixed already!
  2. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  3. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  4. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  5. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
Wkbtjameson
Mon Feb 12, 2018 2:03 pm

x

Need help, having trouble when trying to record vocals over created beat.

Hey guys hows it going, first off I would appreciate any advice. Second, I have been having trouble recording vocals in fl. I have the Takstar Pc-K700, and what most would consider an average audiobox usb (presonus/I believe goes for around $100). I also have no pre amp (which I feel is required and will be getting). **I don't believe I am setting up the mic Incorrectly (or at least I think). I made sure the microphone is selected to the input under my asio panel but yet it seems as if when I try record its still using the microphone from the laptop. I am new to the vocal recording process and would truly appreciate any advice anyone can give. I'm also wondering if maybe I just need to upgrade to a more high quality auiobox? Thanks again.**











Return to “Technical Support (Windows)”