Suddenly unable to open instances of Edirol Orchestral after FL Studio 20 update?

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules

We appreciate it's frustrating when things don't work as expected. However, please help us to help you by following these suggestions:

  1. Simple clear explanation - Explain what you are doing, or trying to do, and exactly what is happening.
  2. Update - Before trying anything else. Download and install the latest version of FL Studio from here. Your bug may be fixed already!
  3. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  4. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  5. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  6. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
Sun Sep 20, 2020 12:40 am


Suddenly unable to open instances of Edirol Orchestral after FL Studio 20 update?

Hello, I really enjoy using FL Studio 20, but after an update a few months back, I suddenly was no longer able to open an instance of Edirol Orchestral. Edirol Orchestral is a free 32bit VST plugin that works fine in other DAWs I own such as Reaper or Cakewalk. It used to work with my early versions of FL Studio 20 before the updates, so I don't know what changed and caused it to no longer work. I have made sure that I tried opening FL Studio using the 32bit option and that doesn't help either.

There are a lot of older compositions I created in FL Studio 20 that use a lot of instruments from Edirol Orchestral, but every time I try to open up these projects, I keep receiving registry key errors when it tries to open up all the tracks using Edirol Orchestral. It is discouraging because I need to fix up these compositions, but now it seems completely impossible. I also noticed that if I try the export all playlist tracks option and try playing the individual exported tracks using VLC player, I get no sounds at all due to the errors I get with Edirol Orchestral within FL Studio 20.

These same registry key errors show up when I try creating a new project and try opening up a new instance of Edirol Orchestral. I really don't want to stop using FL Studio completely because besides this major issue, I am comfortable using the DAW. I have tried all the obvious things already such as uninstalling Edirol Orchestral and reinstalling it, made sure it shows up within the manage plugins section, my MIDI is properly connected, etc.

I would greatly appreciate any help solving this issue.

Return to “Technical Support (Windows)”