Help please, trying to get my Nektar Panorama P1 reconnected [Solved]

Discuss MIDI Controller support/issues here

Return to “MIDI Controller Support”

[You can only see part of this thread as you are not logged in to the forums]
Wed Jan 04, 2023 3:16 pm


Help please, trying to get my Nektar Panorama P1 reconnected [Solved]

Hello all,

>>>>>>>EDIT: IT HAS BEEN SOLVED! Nektar support realised the zip-file in my account did not contain the driver, which it should have. They have now provided me with a new download containing the driver and all is working now as it should. It also picks up the excellent mapping file by Christiano that I used before. Keeping this post up for others: if it's not running, contact Nektar support, they're very helpful. <<<<<<<<

I really need help re-connecting my Nektar Panorama P1 controller. I have had it up and running very well before, but after a sabatical and a change of PC I cannot get it running properly anymore.

I had it up and running very well between 2017 and 2020, posted about it here:
I do see there that another user, jmfisk, has the same issues I have in 2019.

I can connect my P1, and Windows 10 says it's installed and ready. FL Studio can detect it and as per instructions on this forum, I set it up on MIDI port 160 (viewtopic.php?f=1914&t=99692). So far so good.

However, I do not get the full functionality of the P1 back. The top-right buttons (Mixer, Instrument, Transport) don't seem to work, the device stays on the 'Internal' mode. The transport buttons also don't work, however I can see in FL Studio that it does get a signal.

I can assign knobs/faders to controls in FL Studio, but it doesn't pick up on the mapping file in FL Studio's data folder. Sofar it behaves like a standard simple MIDI controller, without the deeper functions of the P1.

If I look at device management in Windows 10, I see it has loaded a Microsoft driver for the P1, not a Nektar driver. I have tried updating the driver within Windows, but cannot locate any Nektar drivers. I had a similar issue reconnecting my Novation Launchkey 61, but a driver download from the Novation website solved all issues. I do not have a driver download on the Nektar website or in my account there.

I did succesfully update the P1 firmware via the download in my Nektar account, but that did not solve the issue.

I have contacted Nektar Support, they told me a driver download should be in my account (it isn't) and to only activate the fourth option in the MIDI setup page in FL. That does not work at all, because configured like that I can see no indication of FL receiving anything (no flashing knob in the hint-screen). It does 'work' if I have the first and fourth option activated (PANORAMA P1 & MIDIIN4). I have responded and am now waiting for a next reply.

There is some interation, but it makes no sense. The 8th fader seems to control the Main mixer fader (if any it should be the 9th fader), but only a useless few cm at the bottom. The Stop transport-button seems to switch one of the three bands in the built in equaliser on a selected mixertrack from fully open to fully closed. The Forward, Reverse and Swith Pattern/Song button seem to select which of the three bands is connected to the Stop button. And, like I said, the three buttons above the LCD screen do not seems to work (Mixer/Instrument/Transport), it stays on Internal.

FL's own member HDSQ told me the mapping system is deprecated, which would explain why the mapping file of Christiano isn't picked up. But it seems like something else is broken in FL'ssupport for the Nektar P1/P4/P6?

I appreciate any help on trying to get it back up and running. I'm also in contact with Nektar support, so any info here or from them I can relay.

kind regards, Frank

Return to “MIDI Controller Support”