20.1.2 Loop step channels treats all channels as step channels if they have no notes

Please report Windows related issues here

Return to “Technical Support (Windows)”

Forum rules
WE NEED DETAILS!

We appreciate your frustration when things don't work as you expected. However, please help us to help you by following these suggestions:

  1. Update - Before anything else, download and install the latest version of FL Studio from here. Your bug may be fixed already!
  2. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  3. Screenshots - Another great way to demonstrate issues. Get a free screenshot app here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  4. A video - The best way of demonstrating many issues. Get a free recorder here. Include mp4 videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  5. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
ALFR3DO
Thu Feb 21, 2019 1:47 am

x

20.1.2 Loop step channels treats all channels as step channels if they have no notes

I'm not sure if it was already reported, but I couldn't find thread with it. If you turn on looping mode in default loop step channels mode, all channels without data (steps or notes) are treated as step channels. If you add new channel, it starts being treated as step channel. Adding notes doesn't change this behaviour, so you have to manually disable looping for the channel. Also looping behaves in a different way than normal notes looping because it ignores note length. Moreover, deleting note data and using steps makes it possible to turn off and on looping and channel will be treated as step channel, but you can't make it work properly with on and off method if channel was treated as step channel at least once - it will always be treated as step channel. Here is video with simplified situation in which I've found the bug:
2019-02-21 01-54-53.mp4
And here is video that tries to show that once mode is set to step channel it doesn't change back:
2019-02-21 02-39-16.mp4
EDIT: At this point I'm not even sure if it's a bug or not.
You do not have the required permissions to view the files attached to this post.

Return to “Technical Support (Windows)”