Issues with connecting Arturia Keylab 49 to FL studio Topic is solved

Please report Mac related issues here

Return to “Technical Support (macOS)”

Forum rules

We appreciate it's frustrating when things don't work as expected. However, please help us to help you by following these suggestions:

  1. Update - Before trying anything else. Download and install the latest version of FL Studio from here. Your bug may be fixed already!
  2. Update plugins - If you are using 3rd party plugins. Look at crash logs for their names. Install the latest version for any you spot. See also Plugins Behaving Badly
  3. Simple clear explanation - Explain what you are doing, or trying to do, and exactly what is happening.
  4. Update macOS - Are you using AT LEAST the last version of macOS High Sierra (10.13.6). Mojave and Catalina are also good.
  5. Specific information - a) FL Studio version & build number, b) what you are doing and what happens exactly, c) step-by-step instructions how reproduce the problem.
  6. Screenshots - Another great way to demonstrate issues. See how here. Include images using the 'Attachments' tab, at the bottom of the post edit window.
  7. A video - The best way of demonstrating many issues - Use QuickTime as shown here. Include videos to your post from the 'Attachments' tab, at the bottom of the post edit window.
  8. Use English - Google Translate your post. Short simple sentences in your original language translate best. We are happy to work this way, no need to worry.

NOTE: Technical Support is ONLY available Monday - Friday (9 am to 5 pm Central European Time), thank you.

ALL posts made in this forum are 'Private' so that only you and staff can see them. This allows sharing of personal data, projects and other information. Posts are generally made public after they are marked 'Solved' AND there was no personal data contained in them.
[You can only see part of this thread as you are not logged in to the forums]
Fri Oct 25, 2019 5:01 am


Arturia KeyLab 49 Essential not playing keys in FL Studio 20.5.1

I recently bought an Arturia 49 essential controller, and I am unable to make FL Studio receive any input from it.

I have updated the firmware on the keyboard. Fl studio is updated. I have followed the instructions on setup from Arturia’s midi control center.

All the controls on the midi controller don’t work except the DAW command center controls. When I open the debug window in FL stuio and play a key, I get the below response.

Mackie Control Universal: 94 45 1F Note On : A5
Handled (first chance) Absolute 0%
Mackie Control Universal: 84 45 47 Note Off: A5

I’ve set the controller type to “mackie control universal”, and set the port in the input and output to 1.

What else can I try?

Fri Oct 25, 2019 5:11 am


Issues with connecting Arturia Keylab 49 to FL studio

Hey, I recently bought a arturia essential 49 ...
You do not have the required permissions to view the files attached to this post.

Return to “Technical Support (macOS)”